subject
Informática, 11.08.2021 15:50 tay5876

Importantes e variadas opções estão disponíveis. Uma dessas opções se baseia em dados que podem ser agrupados em chamados registros. Observe o algoritmo a seguir que traz alguns pontos importantes a serem analisados. PROCEDIMENTO EXIBE ()

DECLARE

J : INTEIRO;

PARA J DE 1 ATÉ 5 FAÇA

ESCREVA (“REGISTRO: “, J);

ESCREVA (“NOME: “, LISTA[J].NOME);

ESCREVA (“TELEFONE: “, LISTA[J].TELEFONE);

FIMPARA;

FIMPROCEDIMENTO;

INÍCIO

DECLARE

TIPO AGENDA = REGISTRO

NOME : CARACTERE [30];

TELEFONE : CARACTERE[20];

FIMREGISTRO;

I : INTEIRO;

LISTA : VETOR [1..5] DE AGENDA;

PARA I DE 1 ATÉ 5 FAÇA

LEIA (LISTA[I].NOME);

LEIA (LISTA[I].TELEFONE);

FIMPARA

EXIBE ();

FIM.

A partir do algoritmo apresentado, analise as afirmativas a seguir:

I – Nesse algoritmo, são utilizados dois tipos de estruturas de dados (variável e registro).

II – Registro é um tipo de estrutura de dados para dados homogêneos e heterogêneos.

III – São permitidos um máximo de 5 registros a cada execução desse algoritmo.

IV – A linha 25 contém a chamada do procedimento da linha 7 que mostra a agenda toda.

É correto o que se afirma em:

Escolha uma opção:
a. I e II, apenas.
b. I, II e III, apenas.
c. I, III e IV, apenas.
d. II, III e IV, apenas.
e. I e IV, apenas.

Respostas
Respostas: 3

Outra pergunta: Informática

question
Informática, 15.08.2019 03:24
Quanto ao conceito de concorrência, assinale a alternativa correta. a o conceito de concorrência é aplicado aos sistemas monotarefas no gerenciamento dos jobs em execução. b a concorrência é o principio básico para o projeto e implementação dos sistemas multiprogramáveis. c o conceito de concorrência foi criado para evitar que múltiplos processos possam ser carregados em memória para compartilhar recursos. d a concorrência permite que apenas um processo possa ser executado na cpu, evitando o compartilhamento de recursos.
Respostas: 1
question
Informática, 16.08.2019 04:21
Como ligo o computador preciso muitoo
Respostas: 2
question
Informática, 17.08.2019 00:46
Alguém sabe como concertar isso em um computador? 15pts
Respostas: 1
question
Informática, 17.08.2019 14:40
Oadobe photoshop gera arquivos num formato default, do tipo matricial, que, com o passar do tempo, assumiu um caráter mais portável e praticamente todos os softwares profissionais o aceitam. de forma similar ao tiff, o formato é capaz de manter as características de qualidade da imagem, proporcionando um ótimo padrão de impressão. esse formato default é conhecido pela sigla:
Respostas: 2
Você sabe a resposta certa?
Importantes e variadas opções estão disponíveis. Uma dessas opções se baseia em dados que podem ser...
Perguntas
question
Português, 20.08.2021 01:20
question
Matemática, 20.08.2021 01:20
question
História, 20.08.2021 01:20
question
ENEM, 20.08.2021 01:20